Welcome to MyRevitive UK

Revitive is plugged in but there is no power or lights.

Follow

1.

Possible Cause

Power adaptor not switched on at the electrical socket or not plugged into the device properly.

Solution

Check electrical socket power is switched on and the power adaptor is plugged into Revitive correctly. If still not working – contact your authorised dealer.

 

2.

Possible Cause

Flat battery.

Solution

Plug device into an electrical socket and charge battery or run using mains power option.

Was this article helpful?
0 out of 3 found this helpful
  • Have a Question?

    Get in touch and one of our team will get back to you as soon as possible

    Submit a request
  • Looking for Help? Join Community

    Couldn't find what you are looking for? Why not join our support forum and let us help you.

    Community