Welcome to MyRevitive UK

Revitive is on (lights illuminated on the LED display) but I cannot feel the electrical stimulation through the foot-pads.

Follow

1.

Possible Cause

Not placing both bare feet on the foot-pads at the same time.

Solution

Ensure that your feet are bare and each foot is placed on each of the foot-pads at the same time. Keep increasing the intensity up to a maximum of 99 until you feel the stimulation.

 

2.

Possible Cause

Your feet may be dry.

Solution

Moisturise the soles of your feet to improve conductivity and stimulation and try the procedure again. You may also have to increase the intensity level.

 

3.

Possible Cause

You may be dehydrated.

Solution

Drink plenty of water before and after using the device. The device uses your body to create the electrical circuit. Water is an excellent conductor of electricity and if your body is less hydrated (below 60%) then the stimulation may be less, therefore it is important to always remain well hydrated.

 

4.

Possible Cause

The intensity level may be on too low a setting.

Solution

This is a very safe device. Keep increasing the intensity level towards 99 until you feel the stimulation. You may find that you have to increase the intensity level as you get used to the therapy. The aim is not to get to 99 but to find a setting that produces strong muscle contractions in your calves and is comfortable for you.

 

5.

Possible Cause

The electrode cord used with the body or knee pads is still connected to device.

Solution

Disconnect the electrode cord - the footpads will not work while the electrode cord is plugged in.

 

6.

Possible Cause

Revitive may be in autopause.

Solution

When the stimulation is paused, sections of the display on the app and Revitive pulse. Tapping play resumes the stimulation and tapping stop ends the stimulation session. Ensure that you have drunk plenty of water, that your feet are well moisturised and both feet are placed on the foot-pads.

 

7.

Possible Cause

If, having tried the solutions above, you still cannot feel the stimulation.

Solution

Test the device by placing one hand across both foot-pads at the same time (The heel end of the foot-pads is easiest). With your other hand, and starting from zero, increase the intensity level until you can feel the stimulation in your hand. If you can feel the stimulation through your hand then the device is working. If on 99 you still cannot feel the stimulation then please contact your authorised dealer.

Was this article helpful?
0 out of 0 found this helpful
  • Have a Question?

    Get in touch and one of our team will get back to you as soon as possible

    Submit a request
  • Looking for Help? Join Community

    Couldn't find what you are looking for? Why not join our support forum and let us help you.

    Community